Symptoms:
Your receive a handshake error in the Collection Management program when trying to communicate with the My Movies WebService, when you are on a satellite connection, or another similar connection with high latency.
Cause:
The satellite connection takes longer to open a connection than other connections before it can communicate with the server in the other end. To avoid interface lock-ups on ordinary connections in situations where the internet is temporary disconnected, the Collection Management program have a low default timeout setting when creating handshakes, which is a security mechanism used to block communication from other applications.
Solution:
The program by default have a connection timeout of 5 seconds, which you can increase by adding a timeout value in the registry. Open the Windows Registry Editor by typing "regedit" in your start menu's command area, and press enter. Locate the key "Computer\HKEY_LOCAL_MACHINE\Software\My Movies\WebService" and click on it - on the right side, right click and choose "New", "DWORD (32-bit value)" - name the new value "MinimumTimeOut", and set it's value to 10 (10 seconds). If this does not resolve the problem, you can try setting it to 15 (seconds) instead.