Issue:
When you contribution a box set, you might see that the progress window stops responding, and after some time you get an error message saying “The WebService did not respond to the request in an expected way”.
Cause:
This might be caused by the fact that it can take a long time for the server to process the data in the box set, and the client then times out before getting a respond from the server. While we are working on a more user friendly solution to this, there is a workaround that you can try.
Solution:
This workaround sets a higher timeout limit (5 minutes) in the client for all contribution calls. So the program will unfortunately still look like it freezes, but it will return after the specified time, or when the server responds to the contribution call.
To use the workaround do the following:
1. Make sure you got the latest version of My Movies installed.
2. Save the attached zip file, and run the file ‘SetContributeTimeout.reg’ that is in it. This file changes a setting in the machines registry. You will be asked if you want to allow this. The change is only done to a setting that is private to My Movies, so there is no harm in it.
3. Do the contribution again.
If this workaround doesn’t fix the problem, then please make a post on our support forum, or contact us through support@mymovies.dk